QBO service disruption affecting Data Syncs and Deductions
Resolved·Full outage

We have fully restored traffic to normal levels and all systems are confirmed to be operating at full health. Our collaboration with the QuickBooks team has been successful in resolving the service disruption that affected Data Syncs and Deductions.

We will continue to monitor traffic vigilantly for any potential regressions through the weekend and remain in close communication with the QuickBooks team during this period. While we consider this issue resolved, we are maintaining heightened monitoring out of an abundance of caution to ensure continued stability.

Fri, Sep 19, 2025, 06:44 PM
(1 month ago)
·
Affected components
Updates

Resolved

We have fully restored traffic to normal levels and all systems are confirmed to be operating at full health. Our collaboration with the QuickBooks team has been successful in resolving the service disruption that affected Data Syncs and Deductions.

We will continue to monitor traffic vigilantly for any potential regressions through the weekend and remain in close communication with the QuickBooks team during this period. While we consider this issue resolved, we are maintaining heightened monitoring out of an abundance of caution to ensure continued stability.

Fri, Sep 19, 2025, 06:44 PM

Monitoring

In collaboration with the QuickBooks team, we have implemented some changes to optimize our request pattern to make more efficient use of the QuickBooks infrastructure. We have begun to ramp up a small percentage of traffic with success, and are coordinating closely with the QuickBooks team to gradually increase traffic over the next few days as we work together to get back to being fully operational.

Wed, Sep 17, 2025, 06:18 PM(2 days earlier)

Identified

We are actively monitoring the situation and working closely with the QBO team to restore service. The impact remains unchanged at this point in time.

Tue, Sep 16, 2025, 08:04 PM(22 hours earlier)

Identified

Data Syncs and Deductions for the QuickBooks integration are currently experiencing an outage due to an upstream service disruption on the QuickBooks platform. We are monitoring the situation and will restore service once the upstream issue is resolved.

Connect authentication may experience intermittent issues but is largely operational.

Sat, Sep 13, 2025, 04:19 AM(3 days earlier)