Elevated Connect errors with Paychex Flex
Monitoring·Partial outage

We have observed continued recurring success over the past day. We are continuing to monitor the situation closely throughout the day to ensure systems are fully stable before marking this issue as resolved.

Mon, Mar 2, 2026, 05:10 PM
(15 hours ago)
·
Affected components
Updates

Monitoring

We have observed continued recurring success over the past day. We are continuing to monitor the situation closely throughout the day to ensure systems are fully stable before marking this issue as resolved.

Mon, Mar 2, 2026, 05:10 PM

Monitoring

We have implemented a fix, have confirmed that recent attempts are succeeding, and are continuing to monitor the results.

Sat, Feb 28, 2026, 01:34 AM(2 days earlier)

Identified

We are currently experiencing elevated Connect auth errors with the Paychex Flex integration. Our team is actively working on a fix and will provide updates as they are available.

Mon, Feb 23, 2026, 06:11 PM(4 days earlier)