Resolved
This incident has been confirmed to be fully resolved.
Monitoring
Data syncs across the affected provider integrations continue to look healthy.
We are continuing to monitor until the queued backlog is fully processed.
Monitoring
We are now seeing recovery with both Paychex Flex and Justworks.
We are continuing to monitor to confirm that full operational health has been restored.
Monitoring
After making a fix, we are seeing recovery with Justworks.
We are continuing to monitor and address any issues across both Paychex Flex and Justworks.
Investigating
We are working on a fix to restore the performance of Data Sync operations for Justworks and Paychex Flex connections.
Previously retrieved data is still accessible as our API remains healthy and fully operational.