High error rates across API

Incident Report for Finch

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 19:08 UTC

Investigating

We are currently investigating this issue.
Posted Apr 15, 2025 - 18:47 UTC
This incident affected: API (api.tryfinch.com), Connect, and Dashboard (dashboard.tryfinch.com).