Service Disruption with ADP Run authentication
Incident Report for Finch
Resolved
Confirming stability, we have seen consistently high success rates over the past week for both Finch Connect auth as well as performance of data syncs. This incident is now resolved.
Posted Sep 23, 2024 - 17:08 UTC
Update
We have made additional changes to improve the auth experience in Finch Connect as well as data syncs performance. We are monitoring the results to confirm that the improvements are stable.
Posted Sep 18, 2024 - 16:26 UTC
Update
We are currently working on additional changes to improve the auth experience in Finch Connect for the ADP Run integration. While we continue to improve this integration, as a failsafe, we have enabled our manual auth fallback flow so that employers are still ensured to have a working option to connect and have data synced. We appreciate your patience as our team continues to work on restoring this integration to its original healthy state.
Posted Jul 19, 2024 - 15:16 UTC
Update
A fix has been implemented to restore authentication via Finch Connect for this integration. We are monitoring the results as we take a phased approach to rolling out the fix.
Posted Jul 17, 2024 - 05:34 UTC
Monitoring
A fix for ongoing Data Sync jobs has been implemented and we are monitoring the results. We are now working to implement a fix Finch Connect.
Posted Jul 16, 2024 - 13:22 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 15, 2024 - 15:38 UTC
Investigating
We are currently investigating an issue with ADP Run authentication that is affecting Finch Connect and Data Sync jobs.
Posted Jul 12, 2024 - 16:11 UTC
This incident affected: Provider Integrations (Run Powered by ADP).