Elevated errors with connectivity to ADP Run and ADP Workforce Now

Incident Report for Finch

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 04:08 UTC

Monitoring

We are observing recovery and will continue to monitor results.
Posted Apr 03, 2025 - 00:15 UTC

Identified

The issue has been identified as an issue with ADP's system. We will continue to monitor for updates from them.
Posted Apr 02, 2025 - 21:25 UTC

Investigating

We are currently investigating this issue.
Posted Apr 02, 2025 - 21:14 UTC
This incident affected: Provider Integrations (Run Powered by ADP, ADP WorkforceNow).