Service Disruption with Quickbooks
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 21:31 UTC
Identified
We are currently experiencing issues with our Quickbooks integration due to an underlying issue with Quickbooks, and are currently monitoring for status updates from them.

More updates and information from Quickbooks can be found on their status page: https://status.quickbooks.intuit.com/
Posted Jul 25, 2024 - 17:20 UTC
This incident affected: Provider Integrations (QuickBooks Payroll).