Elevated Paychex failures in Data syncs
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 22:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2024 - 21:16 UTC
Investigating
We noticed an increase in the number of errors related to Paychex connections starting yesterday at 1 p.m. Eastern Time. The team is currently investigating the cause of the issue.
Posted Nov 13, 2024 - 16:10 UTC
This incident affected: Provider Integrations (Paychex Flex).