Elevated failure rates with data syncs for Deel integration
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Oct 15, 2024 - 19:05 UTC
Investigating
We are experiencing elevated error rates with our integration that is affecting Data Syncs as a result of upstream issues that Deel is currently working through.
Posted Oct 04, 2024 - 19:48 UTC
This incident affected: Provider Integrations (Deel).