Elevated data sync errors with Deel

Incident Report for Finch

Resolved

This incident has been resolved. All connections that experienced data sync failures during this period have been re-run successfully.
Posted Apr 30, 2025 - 02:30 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2025 - 01:02 UTC

Update

We are implementing a fix to support the recent changes in a way that maintains backward compatibility.
Posted Apr 29, 2025 - 23:07 UTC

Identified

We are currently experiencing elevated data sync errors affecting the Deel API integration. The issue originates from Deel's system as a result of a backwards-incompatible change, and we are actively collaborating with their team to work toward a resolution. We will continue to provide updates as we learn more.
Posted Apr 29, 2025 - 20:06 UTC
This incident affected: Provider Integrations (Deel).