Elevated failure rates with data syncs for Deel integration
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 14:24 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2024 - 19:40 UTC
Update
We are still experiencing issues with our Deel integration and awaiting a resolution. We are expecting an update this week that is intended to resolve these issues.
Posted Dec 02, 2024 - 18:45 UTC
Identified
We have identified the issue and are waiting on Deel's response about a resolution. Data Syncs for Deel are still impacted.
Posted Nov 22, 2024 - 22:59 UTC
Investigating
We are experiencing elevated error rates with our integration that is affecting Data Syncs as a result of upstream issues with Deel's API. The team is investigating the issue.
Posted Nov 22, 2024 - 16:27 UTC
This incident affected: Provider Integrations (Deel).