Developer dashboard outage
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Nov 28, 2023 - 22:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 28, 2023 - 22:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 28, 2023 - 22:40 UTC
This incident affected: Dashboard (dashboard.tryfinch.com).