Elevated errors on Justworks
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Jun 23, 2023 - 18:08 UTC
Monitoring
We have been notified of a fix and are monitoring the results. Initial test results are positive.
Posted Jun 23, 2023 - 16:24 UTC
Identified
We are currently experiencing high error rates from Justworks affecting both API requests for data as well as Connect auth. During this time, previously cached data is still available and will continue to be served from our API.
Posted Jun 23, 2023 - 15:00 UTC
This incident affected: Provider Integrations (Justworks).