API, Dashboard and Connect are back online. Partial outage in provider automated jobs.
Incident Report for Finch
Resolved
This incident has been resolved. Data jobs are now being scheduled normally.
Posted Nov 04, 2023 - 15:27 UTC
Identified
We're experiencing a partial outage in provider automated jobs that should be normalized soon.
Posted Nov 04, 2023 - 15:09 UTC
This incident affected: API (api.tryfinch.com), Connect, Dashboard (dashboard.tryfinch.com) and Provider Integrations (BambooHR, bob (HiBob), Gusto, Humaans, Insperity, Justworks, Namely, Paychex Flex, Paycom, Paylocity, Personio, QuickBooks Payroll, Rippling, Run Powered by ADP, Sage HR, Sapling, Sequoia One, Square Payroll, TriNet, UltiPro (UKG Pro), Wave, Workday, Zenefits).