Global IT incident affecting Finch integrations
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 19:55 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 19, 2024 - 15:14 UTC
Monitoring
Finch is aware of the global IT incident that began on July 19th. We have observed overnight performance degradation across a handful of provider integrations. Majority of the impact occurred between the hours of 06:00 UTC and 13:00 UTC. The most heavily impacted integrations were: Quickbooks Payroll, Paylocity, UKG Pro, and Run Powered by ADP. This is not an issue caused by Finch's systems.

While integrations appear to be in a recovered state, we anticipate some intermittent issues over the next few days as providers restore the health of their systems.
Posted Jul 19, 2024 - 15:11 UTC
This incident affected: Provider Integrations (Paylocity, QuickBooks Payroll, Run Powered by ADP, UltiPro (UKG Pro)).