We are experiencing issues with ADP WFN logins
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 16:37 UTC
Identified
We continue to work on this issue as a top priority for our team and expect a resolution soon.
Posted Nov 06, 2022 - 14:36 UTC
Update
We are continuing to investigate this issue.
Posted Oct 26, 2022 - 17:29 UTC
Investigating
We are currently investigating this issue.
Posted Oct 21, 2022 - 16:08 UTC