This incident has been resolved. All previously enqueued deductions requests have been processed and all systems are now back to normal.
Posted Apr 22, 2025 - 16:29 UTC
Monitoring
A fix has been implemented and confirmed working successfully. We are now gradually ramping up the processing of the previously paused asynchronous Justworks deductions queue.
Posted Apr 21, 2025 - 23:00 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 21, 2025 - 19:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 21, 2025 - 18:31 UTC
Update
We are continuing to investigate the issue. While we investigate, we have paused the processing of any Justworks deductions requests. Requests to our API can still be made successfully, and they will be queued up for processing. Processing will reconvene as soon as this issue is resolved. During this time, you may experience some processing delays.
Posted Apr 21, 2025 - 17:22 UTC
Investigating
We are currently investigating an issue with incorrect processing of Justworks deductions enrollments.
Posted Apr 21, 2025 - 17:12 UTC
This incident affected: Provider Integrations (Justworks).