Elevated error rates with Quickbooks auth
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Apr 14, 2024 - 23:14 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2024 - 18:25 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 10, 2024 - 22:47 UTC
Investigating
We are currently investigating an issue with Quickbooks authentication that is affecting Finch Connect.
Posted Apr 10, 2024 - 21:06 UTC
This incident affected: Provider Integrations (QuickBooks Payroll).