Elevated ADP Run authentication failures in Finch Connect
Incident Report for Finch
Resolved
ADP Run authentication via Finch Connect has now normalized. We're marking this incident as resolved.
Posted Nov 12, 2024 - 19:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2024 - 23:50 UTC
Investigating
In light of the previous incident, we are still observing elevated errors with ADP Run authentication via Finch Connect.
Posted Nov 08, 2024 - 16:38 UTC
This incident affected: Provider Integrations (Run Powered by ADP).