High error rates with Justworks data syncs
Incident Report for Finch
Resolved
This incident has been resolved.
Posted Jul 01, 2023 - 01:09 UTC
Monitoring
Results from the fix implemented by Justworks are positive. Performance of data refreshes should now be back to normal. We are still monitoring the results in case of any long-running impact.
Posted Jun 30, 2023 - 22:35 UTC
Identified
The issue has been identified and a fix is being put in place by Justworks.
Posted Jun 30, 2023 - 00:15 UTC
Investigating
We are currently investigating an issue with data syncs experiencing high error rates for Justworks. Previously cached data will continue to be served from the Finch API, but data refreshes may be delayed.
Posted Jun 29, 2023 - 21:11 UTC
This incident affected: Provider Integrations (Justworks).